1 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как сделать кроссворд в excel

Создание кроссворда в программе Microsoft Excel

Многие люди любят разгадывать кроссворды, есть так же лица, которым нравится их составлять. Иногда, составить кроссворд требуется не просто ради развлечения, а, например, чтобы проверить знания учащихся нестандартным способом. Но, мало кто догадывается, что отличным инструментом для создания кроссвордов является программа Microsoft Excel. И, действительно, ячейки на листе данного приложения, как будто специально предназначены для того, чтобы вписывать туда буквы отгадываемых слов. Давайте выясним, как быстро составить кроссворд в программе Microsoft Excel.

Создание кроссворда

Прежде всего, нужно найти готовый кроссворд, с которого вы будете делать копию в программе Excel, или же продумать структуру кроссворда, если вы будете придумывать его полностью сами.

Для кроссворда нужны квадратные ячейки, а не прямоугольные, как по умолчанию в Microsoft Excel. Нам нужно изменить их форму. Для этого, на клавиатуре нажимаем комбинацию клавиш Ctrl+A. Этим мы выделяем весь лист. Затем, кликаем правой кнопкой мыши, чем вызываем контекстное меню. В нём кликаем по пункту «Высота строки».

Открывается небольшое окошко, в котором нужно задать высоту строки. Устанавливаем значение 18. Жмем на кнопку «OK».

Чтобы изменить ширину, кликаем по панели с наименованием столбцов, и в появившемся меню выбираем пункт «Ширина столбца…».

Как и в предыдущем случае, появляется окошко, в которое нужно внести данные. На этот раз это будет число 3. Жмем на кнопку «OK».

Далее, следует подсчитать число клеточек для букв в кроссворде в горизонтальном и вертикальном направлении. Выделяем соответствующее количество ячеек на листе Excel. Находясь во вкладке «Главная», кликаем по кнопке «Граница», которая расположена на ленте в блоке инструментов «Шрифт». В появившемся меню, выбираем пункт «Все границы».

Как видим, границы, очерчивающие наш кроссворд, установлены.

Теперь, следует удалить эти границы в некоторых местах, чтобы кроссворд принял нужный для нас вид. Это можно сделать при помощи такого инструмента, как «Очистить», значок запуска которого имеет форму ластика, и находится в блоке инструментов «Редактирование» всё той же вкладки «Главная». Выделяем границы ячеек, которые хотим стереть и кликаем на данную кнопку.

Таким образом, постепенно прорисовываем наш кроссворд, поочередно удаляя границы, и получаем готовый результат.

Для наглядности, в нашем случае, можно выделить горизонтальную строку кроссворда другим цветом, например желтым, воспользовавшись для этого кнопкой «Цвет заливки» на ленте.

Далее, проставляем номера вопросов на кроссворде. Лучше всего, это делать не слишком большим шрифтом. В нашем случае, использован шрифт 8.

Для того, чтобы разместить сами вопросы, можно кликнуть любую область ячеек в стороне от кроссворда, и нажать на кнопку «Объединить ячейки», которая находится на ленте всё на той же вкладке в блоке инструментов «Выравнивание».

Далее, в большой объединенной ячейке можно пропечатать, или скопировать туда вопросы кроссворда.

Собственно, сам кроссворд на этом готов. Его можно распечатывать, или разгадывать прямо в Экселе.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Читать еще:  Как сделать розу из гофрированной бумаги видео

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Отблагодарите автора, поделитесь статьей в социальных сетях.

Как сделать кроссворд в excel

Проверка правильности решения кроссворда.

Чтобы проверить, правильно ли ученик заполнил кроссворд, нужно сравнить каждое введенное слово с образцом – правильным ответом. Иначе говоря, для каждого слова мы будем сравнивать значения двух ячеек – с введенным словом и правильным ответом, и если они равны, помечать это слово как «верно».

Запишем на свободном месте листа Excel правильные ответы (потом эта информация будет скрыта).

Но если правильный ответ представляет из себя целое слово, записанное в одной ячейке, то ответ ученика – это совокупность нескольких ячеек, в каждой из которых записано по одной букве. Поэтому мы должны ответ ученика преобразовать так, чтобы его можно было сравнить с правильным ответом, то есть соединить отдельные буквы из разных ячеек в целое слово, записанное в одной ячейке. Для этого будем использовать функцию для текстовых величин СЦЕПИТЬ.

Читать еще:  Как сделать папку невидимой в windows 7

· Выделите ячейку, в которой будет записан преобразованный ответ ученика (в моем примере это ячейка, в которой записаны ответы студента ).

· В данной ячейке введите формулу (наберите с клавиатуры или воспользуйтесь командой Вставить функцию на вкладке Формулы): =СЦЕПИТЬ ( ячейка с первой буквой слова; ячейка со второй буквой слова ; ячейка с третьей буквой слова ; т.д.; ).

Теперь можно сравнить правильный ответ с ответом ученика. Для этого будем использовать функцию ЕСЛИ: если слова совпадут, напишем напротив ответа «1», если нет «0». Мы используем числовые значения, а не слова «верно» — «неверно», потому что в дальнейшем проще будет подсчитать количество правильно угаданных слов.

Введите в ячейку : =ЕСЛИ(ячейка с правильным ответом=ячейке с ответом студента;1;0).

С помощью маркера автозаполнения копируем формулу по столбцу на весь необходимый диапазон.

· Ниже напишите «Количество правильных ответов» и введите в соседнюю ячейку формулу: = СУММ(первая ячейка с правильностью ответов: последняя ячейка с правильностью ответов )

Скройте все строки с ответами ученика, правильными ответами и количеством угаданных слов.

Пусть в процессе разгадывания кроссворда на экране высвечивается комментарий «Отлично!», «Хорошо!», «Пока на «троечку»», «Пока не угадано ни одного слова». Для этого введите в ячейку формулу:

=ЕСЛИ(ячейка с количеством отгаданных слов=0;»Пока не угадано ни одного слова»;ЕСЛИ( ячейка с количеством отгаданных слов <17;"Пока на троечку";ЕСЛИ( ячейка с количеством отгаданных слов <20;"хорошо!";"отлично!")))

Создадим кнопку для очистки ячеек кроссворда с использованием макроса.

Нажмите кнопку « Office » , затем «Параметры Excel », выберите в списке с левой стороны открывшегося окна «Настройка», затем из списка вкладок выберите «Разработчик».

В списке команд найдите «Элементы управления» и нажмите кнопку «Добавить», затем кнопку «ОК». Кнопка «Элементы управления» будет добавлена на панель быстрого доступа.

На панели быстрого доступа нажмите кнопку «Элементы управления», «Вставить», «Элементы управления формы», «Кнопка».

Нарисуйте кнопку. Автоматически откроется окно «Назначить макрос объекту». Нажмите на кнопку «Записать», затем «ОК».

Выделите последовательно все клетки кроссворда и удалите из них буквы.

На вкладке Вид выберите Макросы- Остановить запись.

Теперь щелчок левой кнопкой мыши будет запускать макрос, а щелчок правой кнопкой – вызывать контекстное меню.

Чтобы изменить название кнопки, выберите в контекстном меню «Изменить текст» и введите свое название (Очистить кроссворд).

Для правильного функционирования макроса не забудьте перед работой уровень безопасности макроса выбрать Низкий: кнопка Office – Параметры Excel – Центр управления безопасности – Параметры центра – управление безопасностью – Параметры макросов – Включить макросы.

Проверьте работу кроссворда (выставление оценки и кнопку очистки кроссворда).

Создание кроссворда в Microsoft Excel

Автор: Кириллов Владислав Александрович

Очень часто в учебном процессе требуется проверить знания учащихся «не стандартным» способом. И один из этих способов – кроссворд. Далее возникает вопрос реализации этой задачи:

  1. Нахождение вопросов и ответов для кроссворда
  2. Публикация в электронном виде

При выполнении второго пункта рассматриваем основное программное обеспечение, в котором можно выполнить данную задачу. Одна из распространенных программ в которой это выполнимо — Microsoft Excel. Так как практически на любом компьютере присутствует пакет Microsoft Office.

Итак, для того чтобы создать кроссворд в Microsoft Excel, создаем файл и переименовываем его. Открываем и переименовываем листы:

  • Титульный лист;
  • Кроссворд;
  • Обработка результатов.

Переходим на лист «Кроссворд» и выделяем все ячейки, чтобы выставить размер всех ячеек. Выбираем «Формат => Ширина столбца…» и устанавливаем размер 3.

Читать еще:  Как сделать авп из бумаги

Далее «Формат => Высота строки…» устанавливаем высоту строки равную 20 пунктам.

Теперь мы должны заполнить ответы кроссворда так как они будут расположены в кроссворде и рядом пишем пояснение (вопрос).

Что бы расставить номера вопросов есть несколько вариантов:

  • Поставить цифры рядом со словом
  • Поставить примечания на первые буквы слова

Второй вариант мне предпочтителен. Чтобы это сделать нужно:

  1. Выделить ячейку с первой буквой слова
  2. Нажать «Рецензирование => Создать примечание»
  3. Переименовываем в нужный номер вопроса

Далее оформим границы кроссворда.

Для этого выделяем первое слово и зажав кнопку «Ctrl» выделяем все остальные ячейки кроссворда.

Нажимаем «Главная => Формат => Формат ячеек» и настраиваем внешний вид ячеек, самое важное это выбрать «Границы => Внутренние и внешние»

Теперь можно подумать о внешнем виде кроссворда, а именно:

  • Цвет и заливка ячеек;
  • Вставка картинок, как дополнение;
  • Вставка подложки (фон листа).

Первое решается через «Формат ячеек», второе через «Вставка => Рисунки», а третье

Во вкладке «Разметка страницы» нажимаем кнопку «Подложка» и выбираем изображение с компьютера или из коллекции Microsoft.

Убираем сетку, для этого выберем «Вид => Показать или скрыть» и снимем галочку с «Сетка» (Microsoft Office 2007), в Microsoft Office 2013 «Вид» и снимаем галочку с «Сетка».

Оформление листа «Кроссворд» на этом окончено, переходим к листу «Обработка результатов».

На этом листе нужно будет создать некоторую таблицу:

В столбце «А» и «В» вводим номера и ответы на вопросы

Для заполнения столбца «С», нам нужно соединить буквы слова, находящиеся в разных ячейках на странице «Кроссворд» , в одной ячейке. Для этого в ячейке «С2» вставляем функцию «=СЦЕПИТЬ()». Формулу можно прописать вручную или найти в «Функции => Текстовые => СЦЕПИТЬ». Выбираем все ячейки ответа по порядку, зажав кнопку «CTRL» и нажимаем «Enter».

И все тоже выполняем для всех ответов на вопросы.

Далее, заполняем столбец «D», в нем мы должны проверить, соответствуют ли значения столбца «В» значениям столбца «С». Для этого воспользуемся логической функцией «ЕСЛИ». Если значения в ячейках совпадают, то начисляется 1 балл, иначе 0. И так для всех ответов, что бы не вводить везде можно воспользоваться автозаполнением, а лишние выделенные ячейки удалить.

На следующем шаге заполняем «Титульный лист». Само оформление зависит от Вас, но самое главное это добавить ячейки с выводом результата. Вводим текст: «Верное количество ответов» и напротив него вводим формулу «СУММ()». В ней указываем данные на странице результатов, выделяем все ячейки с баллами.

Второй обязательной строчкой будет: «Ваша оценка». Для нее будем использовать функцию «ЕСЛИ» несколько раз. Сначала вводим

Нажимаем «Enter» и вместо «0» в функции опять вставляем «ЕСЛИ», вписываем условие для получения оценки «4»:

Тоже самое для оценки «3», но вместо «0» пишем оценку «2». Так же вместо оценки можно вставлять слова «Умница», «Хорошо», «Удовлетворительно», «Попробуй в следующий раз».

Осталось скрыть лист «Обработка результатов». Для этого нужно нажать правой кнопкой на лист и выбрать «Скрыть».

Или же воспользоваться кнопкой «Формат => Скрыть ли отобразить»

Вместо того чтобы создавать 3 листа все можно было разместить на одном листе. Все что не должен видеть ученик можно так же скрыть. Выделить текст, а потом через «Формат => Скрыть ли отобразить» нажать «Скрыть строки».

Если есть необходимость, то можно защитить книгу, что бы никто кроме Вас не мог отобразить скрытые строки или поменять структуру кроссворда. Нажимаем «Рецензирование => Защитить книгу => Структуру», вводим пароль и подтверждаем.

Выделяем заполненный кроссворд и удаляем ответы.

Видеоурок по созданию кроссворда в Excel

Желаю удачного создания кроссвордов!

Источники:

http://lumpics.ru/how-to-make-a-crossword-in-excel/
http://www.sites.google.com/site/herzencomputerscience/sozdanie
http://www.uchportal.ru/ikt-v-obrazovanii/sozdanie-krossvorda-v-microsoft-excel-6665

Ссылка на основную публикацию
Статьи c упоминанием слов:

Adblock
detector